`from_url` uploads degradation

Incident Report for Uploadcare

Resolved

Although Cloudflare's issues persist and the files they distribute take longer to download via `from_url` than others, our systems remain stable. We are closing the incident but will continue to monitor the situation.
Posted Dec 19, 2025 - 17:31 UTC

Monitoring

`from_url` uploads are processing normally. We're continuing to monitor the situation.
Posted Dec 19, 2025 - 16:38 UTC

Update

`from_url` uploads are now processing normally. Our team monitors the situation.
Posted Dec 19, 2025 - 15:37 UTC

Investigating

We're seeing slow `from_url` uploads processing due to network performance issues at Cloudflare https://www.cloudflarestatus.com/
Since a lot of submitted URLs are hosted by Cloudflare, our `from_url` queue is processing slower than usual.
Posted Dec 19, 2025 - 15:23 UTC
This incident affected: Upload API.